Home Bookmarks Papers Blog

Ipe

Ipe is a wonderful drawing program written by Otfried Cheong. The official web-page is here.

Unfortunately, as far as I know, ipe is no longer maintained and/or/xor supported (probably because Motif is so unprogrammable for humans). If, nevertheless, you want to make it work under linux, you need an updated version of lesstif (0.90 should be good enough, I think), and a X terminal with color depth >8 bits (if you have 8 bits depth, use the old version of ipe).

Anyway, here is a snapshot of ipe on my linux machine. It compiles and works for me, and I hope it works for you. Please dont send bug reports, since for me this program is a black box, and there is no way I can change/modify/improve/disprove it, etc.

Tip: if this still does not work for you, try to recompile it...
Another tip: The old version core dumps on terminals with depth > 8.


An improved version was recently generated by Alexander Wolff.
Mirrored of Alexander Wolff new version: wolff_ipe.tgz
My old version: ipe.tar.gz
A new drawing program that is not there yet, but is moving in the right direction is dia.
Last updated: Fri Jan 19 10:25:00 CST 2001